Browse Source

remove old dddvb-dkms

mango 6 months ago
parent
commit
74b344bfdd

+ 0
- 1
d/dddvb-dkms-0.9.37.0easyVDR0/.pc/.quilt_patches View File

@@ -1 +0,0 @@
1
-debian/patches

+ 0
- 1
d/dddvb-dkms-0.9.37.0easyVDR0/.pc/.quilt_series View File

@@ -1 +0,0 @@
1
-series

+ 0
- 1
d/dddvb-dkms-0.9.37.0easyVDR0/.pc/.version View File

@@ -1 +0,0 @@
1
-2

+ 0
- 0
d/dddvb-dkms-0.9.37.0easyVDR0/.pc/applied-patches View File


+ 0
- 27
d/dddvb-dkms-0.9.37.0easyVDR0/Makefile View File

@@ -1,27 +0,0 @@
1
-#/usr/bin/make
2
-SRC = $(DESTDIR)/usr/src
3
-SHARE = $(DESTDIR)/usr/share/$(NAME)-dkms
4
-
5
-all:
6
-
7
-clean:
8
-
9
-install:
10
-
11
-#source tree
12
-ifeq ("$(wildcard $(NAME)-$(VERSION))", "$(NAME)-$(VERSION)")
13
-	install -d "$(SRC)"
14
-	cp -a $(NAME)-$(VERSION) $(SRC)
15
-endif
16
-
17
-#tarball, possibly with binaries
18
-ifeq ("$(wildcard $(NAME)-$(VERSION).dkms.tar.gz)", "$(NAME)-$(VERSION).dkms.tar.gz")
19
-	install -d "$(SHARE)"
20
-	install -m 644 $(NAME)-$(VERSION).dkms.tar.gz "$(SHARE)"
21
-endif
22
-
23
-#postinst, only if we are supporting legacy mode
24
-ifeq ("$(wildcard common.postinst)", "common.postinst")
25
-	install -d "$(SHARE)"
26
-	install -m 755 $(PREFIX)/usr/lib/dkms/common.postinst $(SHARE)/postinst
27
-endif

+ 0
- 295
d/dddvb-dkms-0.9.37.0easyVDR0/common.postinst View File

@@ -1,295 +0,0 @@
1
-#!/bin/sh
2
-# Copyright (C) 2002-2005 Flavio Stanchina
3
-# Copyright (C) 2005-2006 Aric Cyr
4
-# Copyright (C) 2007 Mario Limonciello
5
-# Copyright (C) 2009 Alberto Milone
6
-
7
-set -e
8
-
9
-uname_s=$(uname -s)
10
-
11
-_get_kernel_dir() {
12
-    KVER=$1
13
-    case ${uname_s} in
14
-	Linux)		DIR="/lib/modules/$KVER/build" ;;
15
-	GNU/kFreeBSD)	DIR="/usr/src/kfreebsd-headers-$KVER/sys" ;;
16
-    esac
17
-    echo $DIR
18
-}
19
-
20
-_check_kernel_dir() {
21
-    DIR=$(_get_kernel_dir $1)
22
-    case ${uname_s} in
23
-	Linux)		test -e $DIR/include ;;
24
-	GNU/kFreeBSD)	test -e $DIR/kern && test -e $DIR/conf/kmod.mk ;;
25
-	*)		return 1 ;;
26
-    esac
27
-    return $?
28
-}
29
-
30
-# Check the existence of a kernel named as $1
31
-_is_kernel_name_correct() {
32
-    CORRECT="no"
33
-    KERNEL_NAME=$1
34
-
35
-    for kernel in /boot/config-*; do
36
-        KERNEL=${kernel#*-}
37
-        if [ "${KERNEL}" = "${KERNEL_NAME}" ]; then
38
-            CORRECT="yes"
39
-            break
40
-        fi
41
-    done
42
-
43
-    echo $CORRECT
44
-}
45
-
46
-
47
-# Get the most recent kernel on Debian based systems. This keeps
48
-# into account both the version and the ABI. If the current kernel
49
-# is the most recent kernel then the function will print a null string.
50
-_get_newest_kernel_debian() {
51
-    NEWEST_KERNEL=
52
-    NEWEST_VERSION=
53
-    NEWEST_ABI=
54
-
55
-    for kernel in /boot/config-*; do
56
-        KERNEL=${kernel#*-}
57
-        KERNEL_VERSION=${KERNEL%%-*}
58
-        ABI=${KERNEL#*-}
59
-        ABI=${ABI%%-*}
60
-
61
-        if [ -z "$NEWEST_KERNEL" ]; then
62
-            # The 1st time get a version which is bigger than $1
63
-            COMPARE_TO=$1
64
-        else
65
-            # Get the biggest version
66
-            COMPARE_TO="$NEWEST_VERSION-$NEWEST_ABI"
67
-        fi
68
-
69
-        # if $kernel is greater than $COMPARE_TO
70
-        if [ `dpkg --compare-versions "$KERNEL_VERSION-$ABI" gt "$COMPARE_TO" && echo "yes" || \
71
-              echo "no"` = "yes" ]; then
72
-            NEWEST_KERNEL=$KERNEL
73
-            NEWEST_VERSION=$KERNEL_VERSION
74
-            NEWEST_ABI=$ABI
75
-        fi
76
-    done
77
-
78
-    echo "$NEWEST_KERNEL"
79
-}
80
-
81
-# Get the most recent kernel in Rhel based systems. If the current kernel
82
-# is the most recent kernel then the function will print a null string.
83
-_get_newest_kernel_rhel() {
84
-    NEWEST_KERNEL=
85
-
86
-    LAST_INSTALLED_KERNEL=$(rpm -q --whatprovides kernel  --last | grep kernel -m1 | cut -f1 -d' ')
87
-
88
-    LIK_FORMATTED_NAME=$(rpm -q $LAST_INSTALLED_KERNEL --queryformat="%{VERSION}-%{RELEASE}.%{ARCH}\n")
89
-
90
-    if [ `echo $LIK_FORMATTED_NAME | grep 2.6 >/dev/null` ]; then
91
-        # Fedora and Suse
92
-        NEWEST_KERNEL=$LIK_FORMATTED_NAME
93
-    else
94
-        # Hack for Mandriva where $LIK_FORMATTED_NAME is broken
95
-        LIK_NAME=$(rpm -q $LAST_INSTALLED_KERNEL --queryformat="%{NAME}\n")
96
-        LIK_TYPE=${LIK_NAME#kernel-}
97
-        LIK_TYPE=${LIK_TYPE%%-*}
98
-        LIK_STRIPPED=${LIK_NAME#kernel-}
99
-        LIK_STRIPPED=${LIK_STRIPPED#$LIK_TYPE-}
100
-        LIK_STRIPPED_BASE=${LIK_STRIPPED%%-*}
101
-        LIK_STRIPPED_END=${LIK_STRIPPED#$LIK_STRIPPED_BASE-}
102
-        LIK_FINAL=$LIK_STRIPPED_BASE-$LIK_TYPE-$LIK_STRIPPED_END
103
-
104
-        NEWEST_KERNEL=$LIK_FINAL
105
-    fi
106
-
107
-    echo $NEWEST_KERNEL
108
-}
109
-
110
-# Get the newest kernel on Debian and Rhel based systems.
111
-get_newest_kernel() {
112
-    NEWEST_KERNEL=
113
-    # Try Debian first as rpm can be installed in Debian based distros
114
-    if [ -e /usr/bin/dpkg ]; then
115
-        # If DEB based
116
-        CURRENT_KERNEL=$1
117
-        CURRENT_VERSION=${CURRENT_KERNEL%%-*}
118
-        CURRENT_ABI=${CURRENT_KERNEL#*-}
119
-        CURRENT_FLAVOUR=${CURRENT_ABI#*-}
120
-        CURRENT_ABI=${CURRENT_ABI%%-*}
121
-        NEWEST_KERNEL=$(_get_newest_kernel_debian "$CURRENT_VERSION-$CURRENT_ABI")
122
-
123
-    elif [ `which rpm >/dev/null` ]; then
124
-        # If RPM based
125
-        NEWEST_KERNEL=$(_get_newest_kernel_rhel)
126
-    fi
127
-
128
-    # Make sure that kernel name that we extracted corresponds to an installed
129
-    # kernel
130
-    if [ -n "$NEWEST_KERNEL" ] && [ `_is_kernel_name_correct $NEWEST_KERNEL` = "no" ]; then
131
-        NEWEST_KERNEL=
132
-    fi
133
-
134
-    echo $NEWEST_KERNEL
135
-}
136
-
137
-NAME=$1
138
-VERSION=$2
139
-TARBALL_ROOT=$3
140
-ARCH=$4
141
-UPGRADE=$5
142
-
143
-if [ -z "$NAME" ] || [ -z "$VERSION" ]; then
144
-    echo "Need NAME, and VERSION defined"
145
-    echo "ARCH is optional"
146
-    exit 1
147
-fi
148
-
149
-KERNELS=$(ls /lib/modules/)
150
-CURRENT_KERNEL=$(uname -r)
151
-
152
-#We never want to keep an older version side by side to prevent conflicts
153
-if [ -e "/var/lib/dkms/$NAME/$VERSION" ]; then
154
-    echo "Removing old $NAME-$VERSION DKMS files..."
155
-    dkms remove -m $NAME -v $VERSION --all
156
-fi
157
-
158
-#Load new files, by source package and by tarball
159
-if [ -f "$TARBALL_ROOT/$NAME-$VERSION.dkms.tar.gz" ]; then
160
-    if ! dkms ldtarball --archive "$TARBALL_ROOT/$NAME-$VERSION.dkms.tar.gz"; then
161
-        echo ""
162
-        echo ""
163
-        echo "Unable to load DKMS tarball $TARBALL_ROOT/$NAME-$VERSION.dkms.tar.gz."
164
-        echo "Common causes include: "
165
-        echo " - You must be using DKMS 2.1.0.0 or later to support binaries only"
166
-        echo "   distribution specific archives."
167
-        echo " - Corrupt distribution specific archive"
168
-        echo ""
169
-        echo ""
170
-        exit 2
171
-    fi
172
-elif [ -d "/usr/src/$NAME-$VERSION" ]; then
173
-    echo "Loading new $NAME-$VERSION DKMS files..."
174
-    dkms add -m $NAME -v $VERSION > /dev/null
175
-fi
176
-
177
-# On 1st installation, let us look for a directory
178
-# in /lib/modules which matches `uname -r`. If none
179
-# is found it is possible that buildd is being used
180
-# and that uname -r is giving us the name of the
181
-# kernel used by the buildd machine.
182
-#
183
-# If this is the case we try to build the kernel
184
-# module for each kernel which has a directory in
185
-# /lib/modules. Furthermore we will have to tell
186
-# DKMS which architecture it should build the module
187
-# for (e.g. if the buildd machine is using a
188
-# 2.6.24-23-xen 64bit kernel).
189
-#
190
-# NOTE: if the headers are not installed then the
191
-#       module won't be built, as usual
192
-if [ -z "$UPGRADE" ]; then
193
-    echo "First Installation: checking all kernels..."
194
-    for KERNEL in $KERNELS; do
195
-        if [ ${KERNEL} = ${CURRENT_KERNEL} ]; then
196
-            # Kernel found
197
-            KERNELS=$CURRENT_KERNEL
198
-            break
199
-        fi
200
-    done
201
-else
202
-    KERNELS=$CURRENT_KERNEL
203
-fi
204
-
205
-# Here we look for the most recent kernel so that we can
206
-# build the module for it (in addition to doing it for the
207
-# current kernel.
208
-NEWEST_KERNEL=$(get_newest_kernel "$KERNELS")
209
-
210
-# If the current kernel doesn't come from the host of a chroot
211
-if [ `_is_kernel_name_correct $CURRENT_KERNEL` = "yes" ]; then
212
-    # See if it's worth building the module for both the newest kernel
213
-    # and for the current kernel
214
-    if [ -n "$NEWEST_KERNEL" ] && [ ${CURRENT_KERNEL} != ${NEWEST_KERNEL} ]; then
215
-        echo "Building for $CURRENT_KERNEL and $NEWEST_KERNEL"
216
-        KERNELS="$CURRENT_KERNEL $NEWEST_KERNEL"
217
-    else
218
-        echo "Building only for $CURRENT_KERNEL"
219
-    fi
220
-# The current kernel is not useful as it's the host's
221
-else
222
-    echo "It is likely that $CURRENT_KERNEL belongs to a chroot's host"
223
-
224
-    # Let's use only the newest kernel
225
-    if [ -n "$NEWEST_KERNEL" ]; then
226
-        KERNELS="$NEWEST_KERNEL"
227
-        echo "Building only for $NEWEST_KERNEL"
228
-    fi
229
-fi
230
-
231
-if [ -n "$ARCH" ]; then
232
-    if which lsb_release >/dev/null && [ $(lsb_release -s -i) = "Ubuntu" ]; then
233
-        case $ARCH in
234
-            amd64)
235
-                ARCH="x86_64"
236
-                ;;
237
-            lpia|i?86)
238
-                ARCH="i686"
239
-                ;;
240
-        esac
241
-    fi
242
-    echo "Building for architecture $ARCH"
243
-    ARCH="-a $ARCH"
244
-fi
245
-
246
-for KERNEL in $KERNELS; do
247
-    dkms_status=`dkms status -m $NAME -v $VERSION -k $KERNEL $ARCH`
248
-    if [ `echo $KERNEL | grep -c "BOOT"` -gt 0 ]; then
249
-        echo ""
250
-        echo "Module build and install for $KERNEL was skipped as "
251
-        echo "it is a BOOT variant"
252
-        continue
253
-    fi
254
-
255
-
256
-    #if the module isn't yet built, try to build it
257
-    if [ `echo $dkms_status | grep -c ": built"` -eq 0 ]; then
258
-        if [ ! -L /var/lib/dkms/$NAME/$VERSION/source ]; then
259
-            echo "This package appears to be a binaries-only package"
260
-            echo " you will not be able to build against kernel $KERNEL"
261
-            echo " since the package source was not provided"
262
-            continue
263
-        fi
264
-        if _check_kernel_dir $KERNEL; then
265
-            echo "Building initial module for $KERNEL"
266
-            set +e
267
-            dkms build -m $NAME -v $VERSION -k $KERNEL $ARCH > /dev/null
268
-            case $? in
269
-            9)
270
-                set -e
271
-                echo "Skipped."
272
-                continue
273
-                ;;
274
-            0)
275
-                set -e
276
-                echo "Done."
277
-                ;;
278
-            *)
279
-                exit $?
280
-                ;;
281
-            esac
282
-            dkms_status=`dkms status -m $NAME -v $VERSION -k $KERNEL $ARCH`
283
-        else
284
-            echo "Module build for the currently running kernel was skipped since the"
285
-            echo "kernel source for this kernel does not seem to be installed."
286
-        fi
287
-    fi
288
-
289
-    #if the module is built (either pre-built or just now), install it
290
-    if [ `echo $dkms_status | grep -c ": built"` -eq 1 ] && 
291
-       [ `echo $dkms_status | grep -c ": installed"` -eq 0 ]; then
292
-        dkms install -m $NAME -v $VERSION -k $KERNEL $ARCH
293
-    fi
294
-done
295
-

+ 0
- 1
d/dddvb-dkms-0.9.37.0easyVDR0/dddvb-0.9.37.0easyVDR0

@@ -1 +0,0 @@
1
-Subproject commit e3601828472485b299495ec15dcd7e4cc4c770a3

+ 0
- 5
d/dddvb-dkms-0.9.37.0easyVDR0/debian/README.Debian View File

@@ -1,5 +0,0 @@
1
-dddvb DKMS module for Debian
2
-
3
-This package was automatically generated by the DKMS system,
4
-for distribution on Debian based operating systems.
5
-

+ 0
- 240
d/dddvb-dkms-0.9.37.0easyVDR0/debian/changelog View File

@@ -1,240 +0,0 @@
1
-dddvb-dkms (2:0.9.37.0easyVDR0-trusty) trusty; urgency=high
2
-
3
-  * new upstream snapshot
4
-  * commit:e360182 - Merge branch 'internal'
5
-  * sources https://github.com/DigitalDevices/dddvb
6
-
7
- -- Wolfgang Mangold <vdr@gmx.de>  Sat, 09 Mar 2019 14:32:41 +0100
8
-
9
-dddvb-dkms (2:0.9.36.0easyVDR0-trusty) trusty; urgency=high
10
-
11
-  * new release 0.9.36
12
-  * sources https://github.com/DigitalDevices/dddvb
13
-
14
- -- Wolfgang Mangold <vdr@gmx.de>  Sun, 28 Oct 2018 17:50:38 +0100
15
-
16
-dddvb-dkms (2:0.9.32.2easyVDR0-trusty) trusty; urgency=high
17
-
18
-  * rebuild
19
-
20
- -- Wolfgang Mangold <vdr@gmx.de>  Wed, 02 May 2018 01:03:21 +0200
21
-
22
-dddvb-dkms (1:0.9.32.1easyVDR0-trusty) trusty; urgency=high
23
-
24
-  * new upstream snapshot
25
-  * commit:0f05b19  - add lock loss irq handler
26
-                    - add modulator ioctl mutex
27
-                    - some more documentation about modulator properties
28
-  * sources https://github.com/DigitalDevices/dddvb
29
-
30
- -- Wolfgang Mangold <vdr@gmx.de>  Fri, 10 Nov 2017 19:36:56 +0100
31
-
32
-dddvb-dkms (1:0.9.32.0easyVDR0-trusty) trusty; urgency=high
33
-
34
-  * new version 0.9.32
35
-  * commit:f84d196 - compiling for kernel 4.12.x
36
-  * sources https://github.com/DigitalDevices/dddvb
37
-
38
- -- Wolfgang Mangold <vdr@gmx.de>  Wed, 27 Sep 2017 22:10:36 +0200
39
-
40
-dddvb-dkms (1:0.9.29.1easyVDR0-trusty) trusty; urgency=high
41
-
42
-  * added dkms.conf
43
-
44
- -- Wolfgang Mangold <vdr@gmx.de>  Fri, 19 May 2017 18:34:16 +0200
45
-
46
-dddvb-dkms (1:0.9.29.0easyVDR0-trusty) trusty; urgency=high
47
-
48
-  * new version 0.9.29
49
-  * commit:01d35aa - New Hardware, fixes, testet up to kernel 4.11.1
50
-  * sources https://github.com/DigitalDevices/dddvb
51
-
52
- -- Wolfgang Mangold <vdr@gmx.de>  Fri, 19 May 2017 17:58:27 +0200
53
-
54
-dddvb-dkms (1:0.9.28~v7a.2easyVDR0-trusty) trusty; urgency=high
55
-
56
-  * Added 0007_cxd2099_buffer_mode.patch thx jasmin-j
57
-  * Added 0008_fix_DMA_buffer_control.patch thx jasmin-j
58
-  * sources https://github.com/jasmin-j/dddvb-dkms/tree/update_to_0_9_28_v7a_ext1
59
-
60
- -- Wolfgang Mangold <vdr@gmx.de>  Mon, 08 May 2017 22:58:22 +0200
61
-
62
-dddvb-dkms (1:0.9.28~v7a.1easyVDR0-trusty) trusty; urgency=high
63
-
64
-  * Added 0006-act_cam_race.patch thx jasmin-j
65
-  * https://github.com/flensrocker/dddvb-dkms/pull/3
66
-
67
- -- Wolfgang Mangold <vdr@gmx.de>  Sat, 18 Mar 2017 18:38:29 +0100
68
-
69
-dddvb-dkms (0.9.28.0easyVDR0-trusty) trusty; urgency=high
70
-
71
-  * new version 0.9.28
72
-  * commit:b6d5976 - support for 24MHz crystals
73
-  * sources https://github.com/DigitalDevices/dddvb
74
-
75
- -- Wolfgang Mangold <vdr@gmx.de>  Sat, 03 Dec 2016 16:53:37 +0100
76
-
77
-dddvb-dkms (0.9.26.0easyVDR0-trusty) trusty; urgency=high
78
-
79
-  * new version 0.9.26
80
-  * sources https://github.com/DigitalDevices/dddvb
81
-
82
- -- Wolfgang Mangold <vdr@gmx.de>  Thu, 15 Sep 2016 21:34:32 +0200
83
-
84
-dddvb-dkms (0.9.24.0easyVDR0-trusty) trusty; urgency=high
85
-
86
-  * new version 0.9.24
87
-  * sources https://github.com/crazycat69/dddvb
88
-
89
- -- Wolfgang Mangold <vdr@gmx.de>  Thu, 18 Aug 2016 21:16:59 +0200
90
-
91
-dddvb-dkms (0.9.23.1easyVDR2-trusty) trusty; urgency=high
92
-
93
-  * switch to sources from CrazyCat all patches included
94
-  * https://bitbucket.org/CrazyCat/dddvb
95
-
96
- -- Wolfgang Mangold <vdr@gmx.de>  Tue, 28 Jun 2016 22:45:51 +0200
97
-
98
-dddvb-dkms (0.9.23.1easyVDR1-trusty) trusty; urgency=high
99
-
100
-  * add max-device patch
101
-
102
- -- Wolfgang Mangold <vdr@gmx.de>  Fri, 24 Jun 2016 00:23:05 +0200
103
-
104
-dddvb-dkms (0.9.23.1easyVDR0-trusty) trusty; urgency=high
105
-
106
-  * added dddvb_verbosity diff
107
-
108
- -- Wolfgang Mangold <vdr@gmx.de>  Sun, 01 May 2016 19:37:04 +0200
109
-
110
-dddvb-dkms (0.9.23.0easyVDR0-trusty) trusty; urgency=high
111
-
112
-  * new upstream version
113
-  * commit: f111d6e - frontends: convert line endings from windows to unix format
114
-
115
- -- Wolfgang Mangold <vdr@gmx.de>  Thu, 14 Apr 2016 19:46:20 +0200
116
-
117
-dddvb-dkms (0.9.22.1easyVDR0-trusty) trusty; urgency=high
118
-
119
-  * added dkms.conf
120
-
121
- -- easyVDR-Developer <easyvdr-dev@easy-vdr.de>  Tue, 26 Jan 2016 15:55:02 +0100
122
-
123
-dddvb-dkms (0.9.22.0easyVDR0-trusty) trusty; urgency=high
124
-
125
-  * new upstream version
126
-  * commit: 781686c - Set version number to 0.9.22
127
-
128
- -- easyVDR-Developer <easyvdr-dev@easy-vdr.de>  Tue, 26 Jan 2016 15:07:56 +0100
129
-
130
-dddvb-dkms (0.9.21.0easyVDR0-trusty) trusty; urgency=high
131
-
132
-  * new upstream version
133
-  * commit: 7eb4ff7 - Release 0.9.21
134
-
135
- -- easyVDR-Developer <easyvdr-dev@easy-vdr.de>  Thu, 17 Dec 2015 23:10:10 +0100
136
-
137
-dddvb-dkms (0.9.19b.0easyVDR0-trusty) trusty; urgency=high
138
-
139
-  * back pack and rebuild for easyVDR
140
-
141
- -- easyVDR-Developer <easyvdr-dev@easy-vdr.de>  Sun, 25 Oct 2015 01:59:02 +0200
142
-
143
-dddvb-dkms (0.9.19b.0yavdr0-trusty) trusty; urgency=medium
144
-
145
-  * new upstream version
146
-
147
- -- Lars Hanisch <dvb@flensrocker.de>  Sat, 11 Jul 2015 12:43:53 +0200
148
-
149
-dddvb-dkms (0.9.17.0yavdr0-trusty) trusty; urgency=medium
150
-
151
-  * new upstream version
152
-
153
- -- Lars Hanisch <dvb@flensrocker.de>  Wed, 21 Jan 2015 20:40:01 +0100
154
-
155
-dddvb-dkms (0.9.14.1yavdr3) trusty; urgency=medium
156
-
157
-  * there was a deleted version 1yavdr2 at Launchpad... :)
158
-
159
- -- Lars Hanisch <dvb@flensrocker.de>  Thu, 14 Aug 2014 23:09:53 +0200
160
-
161
-dddvb-dkms (0.9.14.1yavdr2) trusty; urgency=medium
162
-
163
-  * rebuild with proper version numbers at all places
164
-
165
- -- Lars Hanisch <dvb@flensrocker.de>  Thu, 14 Aug 2014 18:40:37 +0200
166
-
167
-dddvb-dkms (0.9.14.1yavdr0) precise; urgency=medium
168
-
169
-  * new upstream bugfix patch
170
-
171
- -- Lars Hanisch <dvb@flensrocker.de>  Sun, 27 Apr 2014 14:23:14 +0200
172
-
173
-dddvb-dkms (0.9.14.0yavdr0) precise; urgency=medium
174
-
175
-  * new upstream version
176
-  * adjust all patches
177
-
178
- -- Lars Hanisch <dvb@flensrocker.de>  Fri, 25 Apr 2014 00:23:26 +0200
179
-
180
-dddvb-dkms (0.9.13.2yavdr0) precise; urgency=medium
181
-
182
-  * add pci-id for C/T V7
183
-
184
- -- Lars Hanisch <dvb@flensrocker.de>  Wed, 16 Apr 2014 18:23:37 +0200
185
-
186
-dddvb-dkms (0.9.13.1yavdr0) precise; urgency=medium
187
-
188
-  * add clr-dma-buffer-on-open-fix patch
189
-
190
- -- Lars Hanisch <dvb@flensrocker.de>  Sun, 13 Apr 2014 10:11:08 +0200
191
-
192
-dddvb-dkms (0.9.13.0yavdr0) precise; urgency=medium
193
-
194
-  * new upstream version
195
-  * add remove-188-byte-limit-in-ts-write patch
196
-
197
- -- Lars Hanisch <dvb@flensrocker.de>  Thu, 10 Apr 2014 20:00:24 +0200
198
-
199
-dddvb-dkms (0.9.12.0yavdr0) precise; urgency=medium
200
-
201
-  * new upstream version
202
-
203
- -- Lars Hanisch <dvb@flensrocker.de>  Wed, 12 Mar 2014 18:42:04 +0100
204
-
205
-dddvb-dkms (0.9.10.6yavdr0) precise; urgency=medium
206
-
207
-  * stv090x: don't use DBVALS
208
-
209
- -- Lars Hanisch <dvb@flensrocker.de>  Tue, 12 Nov 2013 22:17:17 +0100
210
-
211
-dddvb-dkms (0.9.10.5yavdr0) precise; urgency=medium
212
-
213
-  * add lnbp21 to srcversion.diff
214
-
215
- -- Lars Hanisch <dvb@flensrocker.de>  Sat, 09 Nov 2013 18:54:31 +0100
216
-
217
-dddvb-dkms (0.9.10.4yavdr0) precise; urgency=medium
218
-
219
-  * add cxd2843 to dkms.conf
220
-  * add stv6110x_srcversion.diff so module will always be installed
221
-
222
- -- Lars Hanisch <dvb@flensrocker.de>  Sat, 09 Nov 2013 09:54:49 +0100
223
-
224
-dddvb-dkms (0.9.10.3yavdr0) precise; urgency=medium
225
-
226
-  * add drxk_lockstatus_fix.diff
227
-
228
- -- Lars Hanisch <dvb@flensrocker.de>  Thu, 07 Nov 2013 19:00:05 +0100
229
-
230
-dddvb-dkms (0.9.10.2yavdr0) precise; urgency=medium
231
-
232
-  * use drxk and tda18271c2dd from Oliver Endriss' repository
233
-
234
- -- Lars Hanisch <dvb@flensrocker.de>  Wed, 06 Nov 2013 23:30:46 +0100
235
-
236
-dddvb-dkms (0.9.10-1yavdr1~precise) precise; urgency=medium
237
-
238
-  * initial build
239
-
240
- -- Gerald Dachs <gda@dachsweb.de>  Tue, 05 Nov 2013 11:11:12 +0100

+ 0
- 1
d/dddvb-dkms-0.9.37.0easyVDR0/debian/compat View File

@@ -1 +0,0 @@
1
-7

+ 0
- 14
d/dddvb-dkms-0.9.37.0easyVDR0/debian/control View File

@@ -1,14 +0,0 @@
1
-Source: dddvb-dkms
2
-Section: misc
3
-Priority: optional
4
-Maintainer: Lars Hanisch <dvb@flensrocker.de>, Wolfgang Mangold <vdr@gmx.de>
5
-Uploaders: Wolfgang Mangold <vdr@gmx.de>
6
-Build-Depends: debhelper (>= 8), dkms, libproc-processtable-perl, python-apport
7
-Standards-Version: 3.9.5
8
-
9
-Package: dddvb-dkms
10
-Architecture: all
11
-Depends: dkms (>= 1.95), ${misc:Depends}
12
-Conflicts: s2-liplianin-dkms, v4l-dvb-dkms, linux-tbs-drivers-dkms, linux-media-tbs-dkms, linux-media-dkms, linux-media, linux-media-comp, linux-media-dvbsky-c, linux-media-dvbsky, media-build-experimental-dkms
13
-Replaces: s2-liplianin-dkms, v4l-dvb-dkms, linux-tbs-drivers-dkms, linux-media-tbs-dkms, linux-media-dkms, linux-media, linux-media-comp, linux-media-dvbsky-c, linux-media-dvbsky, media-build-experimental-dkms
14
-Description: dddvb driver in DKMS format.

+ 0
- 2
d/dddvb-dkms-0.9.37.0easyVDR0/debian/copyright View File

@@ -1,2 +0,0 @@
1
-
2
-This copyright has not been completed by the author of this package.

+ 0
- 1
d/dddvb-dkms-0.9.37.0easyVDR0/debian/dirs View File

@@ -1 +0,0 @@
1
-usr/src

+ 0
- 51
d/dddvb-dkms-0.9.37.0easyVDR0/debian/postinst View File

@@ -1,51 +0,0 @@
1
-#!/bin/sh
2
-# Copyright (C) 2002-2005 Flavio Stanchina
3
-# Copyright (C) 2005-2006 Aric Cyr
4
-# Copyright (C) 2007 Mario Limonciello
5
-# Copyright (C) 2009 Alberto Milone
6
-
7
-set -e
8
-
9
-NAME=dddvb
10
-PACKAGE_NAME=$NAME-dkms
11
-CVERSION=`dpkg-query -W -f='${Version}' $PACKAGE_NAME | awk -F "-" '{print $1}' | cut -d\: -f2`
12
-ARCH=`dpkg --print-architecture`
13
-
14
-dkms_configure () {
15
-	for POSTINST in /usr/lib/dkms/common.postinst "/usr/share/$PACKAGE_NAME/postinst"; do
16
-		if [ -f "$POSTINST" ]; then
17
-			"$POSTINST" "$NAME" "$CVERSION" "/usr/share/$PACKAGE_NAME" "$ARCH" "$2"
18
-			return $?
19
-		fi
20
-		echo "WARNING: $POSTINST does not exist." >&2
21
-	done
22
-	echo "ERROR: DKMS version is too old and $PACKAGE_NAME was not" >&2
23
-	echo "built with legacy DKMS support." >&2
24
-	echo "You must either rebuild $PACKAGE_NAME with legacy postinst" >&2
25
-	echo "support or upgrade DKMS to a more current version." >&2
26
-	return 1
27
-}
28
-
29
-case "$1" in
30
-	configure)
31
-	        echo "#dddvb dkms-paket" >  /tmp/DriverMakeInfo
32
-                echo "LogFile=\"/var/lib/dkms/dddvb/*easy*/build/make.log\""  >>  /tmp/DriverMakeInfo
33
-                echo "LogSize=21307" >>  /tmp/DriverMakeInfo
34
-		dkms_configure
35
-	;;
36
-
37
-	abort-upgrade|abort-remove|abort-deconfigure)
38
-	;;
39
-
40
-	*)
41
-		echo "postinst called with unknown argument \`$1'" >&2
42
-		exit 1
43
-	;;
44
-esac
45
-
46
-# dh_installdeb will replace this with shell code automatically
47
-# generated by other debhelper scripts.
48
-
49
-#DEBHELPER#
50
-
51
-exit 0

+ 0
- 28
d/dddvb-dkms-0.9.37.0easyVDR0/debian/prerm View File

@@ -1,28 +0,0 @@
1
-#!/bin/sh
2
-
3
-NAME=dddvb
4
-VERSION=0.9.37.0easyVDR0
5
-
6
-set -e
7
-
8
-case "$1" in
9
-    remove|upgrade|deconfigure)
10
-      if [  "`dkms status -m $NAME`" ]; then
11
-         dkms remove -m $NAME -v $VERSION --all
12
-      fi
13
-    ;;
14
-
15
-    failed-upgrade)
16
-    ;;
17
-
18
-    *)
19
-        echo "prerm called with unknown argument \`$1'" >&2
20
-        exit 1
21
-    ;;
22
-esac
23
-
24
-#DEBHELPER#
25
-
26
-exit 0
27
-
28
-

+ 0
- 58
d/dddvb-dkms-0.9.37.0easyVDR0/debian/rules View File

@@ -1,58 +0,0 @@
1
-#!/usr/bin/make -f
2
-# -*- makefile -*-
3
-
4
-# Uncomment this to turn on verbose mode.
5
-#export DH_VERBOSE=1
6
-
7
-DEB_NAME=dddvb
8
-NAME=dddvb
9
-VERSION=0.9.37.0easyVDR0
10
-
11
-configure: configure-stamp
12
-configure-stamp:
13
-	dh_testdir
14
-	touch configure-stamp
15
-
16
-
17
-build: build-stamp
18
-
19
-build-stamp: configure-stamp 
20
-	dh_testdir
21
-	$(MAKE)
22
-	touch $@
23
-
24
-clean:
25
-	dh_testdir
26
-	dh_testroot
27
-	rm -f build-stamp configure-stamp
28
-	-$(MAKE) clean
29
-	dh_clean
30
-
31
-install: build
32
-	dh_testdir
33
-	dh_testroot
34
-	dh_prep
35
-	dh_installdirs
36
-	$(MAKE) DESTDIR=$(CURDIR)/debian/$(DEB_NAME)-dkms NAME=$(NAME) VERSION=$(VERSION) install
37
-
38
-binary-arch: build install
39
-
40
-binary-indep: build install
41
-	dh_testdir
42
-	dh_testroot
43
-	dh_link
44
-	dh_strip
45
-	dh_compress
46
-	dh_fixperms
47
-	dh_installdeb
48
-	#dh_shlibdeps
49
-	dh_gencontrol
50
-	dh_md5sums
51
-	dh_builddeb
52
-
53
-binary: binary-indep binary-arch
54
-
55
-make-orig:
56
-	git archive --format=tar.gz --prefix=dddvb-dkms-$(VERSION)/ -o ../dddvb-dkms_$(VERSION).orig.tar.gz master
57
-
58
-.PHONY: build clean binary-indep binary-arch binary install configure make-orig

+ 0
- 1
d/dddvb-dkms-0.9.37.0easyVDR0/debian/source/format View File

@@ -1 +0,0 @@
1
-3.0 (quilt)

+ 0
- 1
d/dddvb-dkms-0.9.37.0easyVDR0/debian/source/options View File

@@ -1 +0,0 @@
1
-compression = "xz" 

BIN
d/dddvb-dkms_0.9.37.0easyVDR0.orig.tar.xz View File


Loading…
Cancel
Save